Home > Usr Bin Ld Cannot > Usr/bin/ld Cannot Find Lpam Debian

Usr/bin/ld Cannot Find Lpam Debian

However if I tried to install it globally, I wouldn't have any problem at all. :\ –cballenar Jul 22 at 15:02 add a comment| up vote 25 down vote I just I did a Google search for "pluggable authentication module" and the first hit is www.kernel.org/pub/linux/libs/pam. Teenage daughter refusing to go to school How can I open the next/previous file alphabetically? Last modified: Fri Nov 11 00:55:05 2016; Machine Name: beach Debian Bug tracking system Copyright (C) 1999 Darren O. http://rinfix.com/usr-bin-ld-cannot/usr-bin-ld-cannot-find-lxt.html

yes checking security/pam_appl.h usability... Last edited by knudfl; 01-15-2010 at 03:07 AM. Debian bug tracking system administrator . Message #15 received at [email protected] (full text, mbox, reply): From: Evgeni Golov To: [email protected] Subject: Re: [Pkg-postgresql-public] Bug#717073: The libpq-dev package misses some dependencies Date: Tue, 16 Jul 2013 16:15:56

Original comment by koposov on 26 Jan 2014 at 11:06 Changed state: Invalid Added labels: **** Removed labels: **** GoogleCodeExporter commented Mar 28, 2015 I have the same problem with ubuntu glibc-2.5-42.el5_4.3.i686 100% |=========================| 150 kB 00:09 ---> Package glibc.i686 0:2.5-42.el5_4.3 set to be updated --> Running transaction check --> Processing Dependency: glibc = 2.5-18 for package: glibc-headers --> Processing Dependency: audit-libs And welcome to LQ. ..... You are currently viewing LQ as a guest.

  1. Original comment by [email protected] on 26 Jan 2014 at 10:28 Added labels: **** Removed labels: **** GoogleCodeExporter commented Mar 28, 2015 No problem.
  2. Now, you can compile mini_sendmail without any problem under RHEL 6.
  3. knudfl View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by knudfl 01-14-2010, 10:23 AM #3 ted_s LQ Newbie Registered: Jan 2010 Posts:
  4. Reload to refresh your session. UNIX & Linux Forums > Top Forums > Programming Member Name Remember Me?
  5. Personal Open source Business Explore Sign up Sign in Pricing Blog Support Search GitHub This repository Watch 6 Star 8 Fork 4 segasai/q3c Code Issues 0 Pull requests 0 Projects
  6. Password Forgot Password?
  7. gcc -o sudo sudo_auth.o pam.o mkstemps.o ldap.o exec_pty.o get_pty.o iolog.o audit.o boottime.o check.o env.o exec.o getspwuid.o gettime.o goodpath.o fileops.o find_path.o interfaces.o lbuf.o logging.o parse.o parse_args.o set_perms.o sudo.o sudo_edit.o sudo_nss.o tgetpass.o -L.
  8. I fixed by installing the relating packages mentioned in the second comment.
  9. Thanks so much, Ted S.
  10. By joining our community you will have the ability to post topics, receive our newsletter, use the advanced search, subscribe to threads and access many other special features.

Nod. Bug archived. Faced this problem during installing runit.If someone faces just install glibc-static. :) Reply Link me February 10, 2016, 4:39 pmi'm building an rpm package from source(pg_bulkload) and i get this error--truncated-- Reload to refresh your session.

cc -g -O2 -o apitest apitest.o ./.libs/libldap.a /usr/local/src/openldap/openldap-2.1.25/libraries/liblber/.libs/liblber. Some systems use LD_LIBRARY_PATH. Nope, the real issue is that pg_config is not pkg-config :) pg_config --help says --libs show LIBS value used when PostgreSQL was built So it has nothing in common with pkg-config Find the "unwrapped size" of a list Possible repercussions from assault between coworkers outside the office Polyglot Anagrams Cops' Thread US Election results 2016: What went wrong with prediction models?

But I'm getting the following error after tying the make command:

gcc -O -c mini_sendmail.c gcc -O -s -static mini_sendmail.o -o mini_sendmail /usr/bin/ld: cannot find -lc collect2: ld returned 1 exit Posts: 16,276 Rep: ' lpam ' means ' libpam.so ', which is provided by the package ' libpam-devel '. It's free: ©2000-2016 nixCraft. more stack exchange communities company blog Stack Exchange Inbox Reputation and Badges sign up log in tour help Tour Start here for a quick overview of the site Help Center Detailed

Reported by: Pierre Pronchery Date: Tue, 16 Jul 2013 13:51:02 UTC Severity: important Found in version postgresql-9.1/9.1.9-0wheezy1 Done: Christoph Berg Bug is archived. Copy sent to Debian PostgreSQL Maintainers . (Tue, 16 Jul 2013 14:27:04 GMT) Full text and rfc822 format available. What does cannot find -lz mean? Send a report that this bug log contains spam.

yes checking whether to use PAM session support... have a peek at these guys The server i'm installing the latest version of LDAP on Debian 3.0. Acknowledgement sent to Pierre Pronchery : Extra info received and forwarded to list. Bug?

Try installing pam-devel-0.77-66.26.ppc and see if that makes a difference. com> Date: 2004-01-16 15:56:02 Message-ID: LYRIS-886202-549485-2004.01.16-10.56.36--ldap#progressive-comp.com () listserver ! Thank you :) –phedoreanu Dec 18 '15 at 11:55 add a comment| 9 Answers 9 active oldest votes up vote 120 down vote I had the exact same error, and like check over here Skip to content Ignore Learn more Please note that GitHub no longer supports old versions of Firefox.

My boss asks me to stop writing small functions and do everything in the same loop GO OUT AND VOTE Can an object *immediately* start moving at a high velocity? Click Here to receive this Complete Guide absolutely free. You signed out in another tab or window.

yes checking security/pam_appl.h usability...

LinuxQuestions.org > Forums > Linux Forums > Linux - Server fedora7 make error - /usr/bin/ld: cannot find -lpam User Name Remember Me? audit-1.7.13-2.el5.i386.r 100% |=========================| 21 kB 00:01 ---> Package audit.i386 0:1.7.13-2.el5 set to be updated ---> Downloading header for glibc-devel to pack into transaction set. But mini_sendmail is specially used for chrooted setup. Note that registered members see fewer ads, and ContentLink is completely disabled once you log in.

Message #20 received at [email protected] (full text, mbox, reply): From: Christoph Berg To: Pierre Pronchery , [email protected], Evgeni Golov Cc: [email protected] Subject: Re: Bug#717073: The libpq-dev package misses some Share this tutorial on:TwitterFacebookGoogle+Download PDF version Found an error/typo on this page?About the author: Vivek Gite is a seasoned sysadmin and a trainer for the Linux/Unix & shell scripting. There was very little information about this problem after googling and checking the LDAP archives. this content Please note that RHEL v5 and earlier included static lib in glibc-devel itself.

Can I download it and install it manually from somewhere? Registration is quick, simple and absolutely free. Sekullos Shell Programming and Scripting 7 08-09-2011 10:27 PM Simplified find command to find multiple file types vickramshetty Linux 2 05-28-2010 02:28 PM how to find a file named vijay in edu [Download message RAW] Hello, It appears that either you don't have the "pam" library or it isn't on the path in the proper environment variable.

Done zlib1g-dev is already the newest version. (I get that from this link.) linux gcc linker share|improve this question edited Oct 22 '12 at 22:31 Keith Pinson 3,68842966 asked Jul 30 All rights reserved. yes checking for log file location... /var/log/sudo.log checking for timestamp file location... /var/run/sudo configure: using the following authentication methods: pam configure: creating ./config.status config.status: creating Makefile config.status: creating sudo.man config.status: creating EDIT : Sorry, typo : Package name = pam-devel . ( libpam.so is a link to libpam.so.0.81.6 ) ..... ..

If the latter, you should probably be including postgres_fe.h not postgres.h. > /usr/bin/ld: cannot find -lxslt > /usr/bin/ld: cannot find -lxml2 > /usr/bin/ld: cannot find -lpam > /usr/bin/ld: cannot find -ledit Acknowledgement sent to Peter Eisentraut : Extra info received and forwarded to list. Now when I run make I am presented with this error at the end of the output. Try installing pam-devel-0.77-66.26.ppc and see if that makes a difference.

no checking security/pam_appl.h presence... Original comment by [email protected] on 24 Mar 2015 at 2:34 Added labels: **** Removed labels: **** Sign up for free to join this conversation on GitHub. Register All Albums FAQ Today's Posts Search Programming & Packaging A place to discuss programming and packaging. no checking pam/pam_appl.h presence...

Copy sent to Debian PostgreSQL Maintainers . (Tue, 16 Jul 2013 14:12:20 GMT) Full text and rfc822 format available. Regarding removing the requirement for packages, I'd better keep them, as q3c don't have control over whatever is included in PG macroses and functions, so they could easily have the dependencies You need to install the glibc-static package. If you do "man cc" the man page might tell you.

Best, -- khorben Information forwarded to [email protected], Debian PostgreSQL Maintainers : Bug#717073; Package libpq-dev. (Tue, 16 Jul 2013 14:27:04 GMT) Full text and rfc822 format available. For more advanced trainees it can be a desktop reference, and a collection of the base knowledge needed to proceed with system and network administration.