Home > Usr Bin Ld Cannot > Usr/bin/ld Cannot Find Lmysqlclient Gem

Usr/bin/ld Cannot Find Lmysqlclient Gem

yes checking for mysqld_error.h... Any help would be appreciated. THX in advance for the heads up. User contributions on this site are licensed under the Creative Commons Attribution Share Alike 4.0 International License. weblink

Gem::Installer::ExtensionBuildError: ERROR: Failed to build gem native extension. /opt/rh/ruby193/root/usr/bin/ruby extconf.rb checking for ruby/thread.h... The initial build for the application failed: Shell command '/sbin/runuser -s /bin/sh 53a837ab0061c5545c000061 -c "exec /usr/bin/runcon 'unconfined_u:system_r:openshift_t:s0:c0,c1001' /bin/sh -c \"gear postreceive --init >> /tmp/initial-build.log 2>&1\""' returned an error. yes ----- Using mysql_config at /opt/rh/mysql55/root/usr/bin/mysql_config ----- checking for mysql.h... yes creating Makefile make gcc -I. -I. -I/usr/lib64/ruby/1.8/x86_64-linux -I. -DHAVE_MYSQL_H -I/opt/rh/mysql55/root/usr/include/mysql -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -fno-strict-aliasing -fwrapv -fPIC -fPIC -g -static-libgcc -fno-omit-frame-pointer -fno-strict-aliasing -DMY_PTHREAD_FASTMUTEX=1 -fPIC

share|improve this answer answered Oct 13 '11 at 13:36 nathan 3,18922237 add a comment| up vote 0 down vote I'd recommend that you use the mysql2 gem. Do you want to help us debug the posting issues ? < is the place to report it, thanks ! yes creating Makefile make gcc -I. -I. -I/usr/local/lib/ruby/1.8/x86_64-linux -I. -DHAVE_MYSQL_H -I/usr/include/mysql -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -fasynchronous-unwind-tables -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -fno-strict-aliasing -fwrapv -fPIC -DUNIV_LINUX -DUNIV_LINUX -fPIC -g -O2 -c

  • Powered by Blogger.
  • yes checking for rb_intern3()...
  • yes checking for rb_thread_blocking_region()...
  • no checking for rb_str_set_len()...
  • Results logged to /var/lib/openshift/53a837ab0061c5545c000061/app-root/runtime/repo/vendor/bundle/ruby/1.8/gems/mysql-2.8.1/ext/mysql_api/gem_make.out An error occurred while installing mysql (2.8.1), and Bundler cannot continue.
  • no checking for rb_str_set_len()...

Check the mkmf.log file for more remote: details. Will I get the same result if I use 18-55mm lens at 55mm (full zoom) and 55-200mm lens at 55mm (no zoom), if not, then why? Navigate:Previous Message•Next Message Options:Reply•Quote Subject Written By Posted gem install mysql2 :: Error cannot find -lmysqlclient_r Bernardino Lopez 08/09/2011 03:27PM Sorry, you can't reply to this topic. On Apr 7, 10:53 am, Frederick Cheung Report post Edit Delete Reply with quote Re: "gem install mysql" fails Frederick Cheung (Guest) on 2009-04-07 20:22 On Apr 7, 6:14 pm, sporkit

yes checking for rb_hash_dup()... Ubuntu Ubuntu Insights Planet Ubuntu Activity Page Please read before SSO login Advanced Search Forum The Ubuntu Forum Community Ubuntu Official Flavours Support General Help [SOLVED] RubyOnRails rails new error Having Results logged to /var/lib/openshift/53a7d8bcd14d1533f9000025/app-root/runtime/repo/vendor/bundle/ruby/1.8/gems/mysql-2.8.1/ext/mysql_api/gem_make.out An error occurred while installing mysql (2.8.1), and Bundler cannot continue. Last edit at 08/09/2011 03:31PM by Bernardino Lopez.

It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party. remote: from /opt/rh/ruby193/root/usr/share/ruby/mkmf.rb:461:in `try_link0' remote: from /opt/rh/ruby193/root/usr/share/ruby/mkmf.rb:476:in `try_link' remote: from /opt/rh/ruby193/root/usr/share/ruby/mkmf.rb:619:in `try_func' remote: from /opt/rh/ruby193/root/usr/share/ruby/mkmf.rb:894:in `block in have_func' remote: from /opt/rh/ruby193/root/usr/share/ruby/mkmf.rb:790:in `block in checking_for' remote: from /opt/rh/ruby193/root/usr/share/ruby/mkmf.rb:284:in `block (2 levels) in no sqlite3.h is missing. john: find / -name gem /usr/local/bin/gem /usr/local/lib/ruby/gems/1.8/gems/rubygems-update-1.3.1/bin/gem /usr/local/lib/ruby/gems/1.9.1/gems/rubygems-update-1.3.1/bin/gem running /usr/local/lib/ruby/gems/1.8/gems/rubygems-update-1.3.1/bin/gem list /usr/local/lib/ruby/gems/1.9.1/gems/rubygems-update-1.3.1/bin/gem list produce the same output.

I have rad a lot of tutorials where is told that I have to include mysql_config to get rid of this error, but there is no help from that. This could take a while... Contact information - E-Mail: webmaster (at) ruby-forum (dot) com. ֥ȥå ̵֥ komiyak̤ƻ <饤󥹥ϡ˥...|Rails: Asset Pipeline: product...> 2015-01-20 Ruby, gem install mysql2, -lmysqlclient Ĥޤ Ruby mysql2 Ȥ gem 򥤥󥹥ȡ뤹Ȥ˵ˤĤơ Register here.

This could take a while... have a peek at these guys yes creating Makefile make gcc -I. -I. -I/usr/lib64/ruby/1.8/x86_64-linux -I. -DHAVE_MYSQL_H -I/opt/rh/mysql55/root/usr/include/mysql -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -fno-strict-aliasing -fwrapv -fPIC -fPIC -g -static-libgcc -fno-omit-frame-pointer -fno-strict-aliasing -DMY_PTHREAD_FASTMUTEX=1 -fPIC Limit computation technology in a futuristic society GO OUT AND VOTE Symmetric group action on Young Tableaux Possible repercussions from assault between coworkers outside the office How to stop NPCs from Results logged to /usr/local/lib/ruby/gems/1.8/gems/mysql-2.8.1/ext/mysql_api/gem_make.out Any suggestions?

You may need configuration options. remote: Results logged to /var/lib/openshift/539ef47f6feb46986c0004b9/app-root/runtime/repo/vendor/bundle/ruby/1.9.1/gems/mysql-2.9.1/ext/mysql_api/gem_make.out remote: An error occurred while installing mysql (2.9.1), and Bundler cannot continue. The initial build for the application failed: Shell command '/sbin/runuser -s /bin/sh 53a2d5b8f1da18b84c0000b3 -c "exec /usr/bin/runcon 'unconfined_u:system_r:openshift_t:s0:c0,c1014' /bin/sh -c \"gear postreceive --init >> /tmp/initial-build.log 2>&1\""' returned an error. check over here So I just had to type the following commands Code: sudo apt-get install mysql-client sudo apt-get install libmysql-ruby libmysqlclient-dev sudo gem install mysql And then it worked , I got the

yes checking for mysqld_error.h... Bug1109645 - gem install mysql failed when ruby scalable app with mysql-5.5 Summary: gem install mysql failed when ruby scalable app with mysql-5.5 Status: CLOSED CURRENTRELEASE Aliases: None Product: OpenShift Online Now I dunno what is the problem with Ruby 1.8, my guess would be that it fails because 'mysql2' gem is not compatible with Ruby 1.8 OR the ruby 1.8 bundler

DistroUbuntu 10.04 Lucid Lynx Re: RubyOnRails rails new error It looks like you may need to install mysql?

Adv Reply October 5th, 2011 #7 seawolf167 View Profile View Forum Posts Private Message I Ubuntu, Therefore, I Am Join Date Mar 2010 Location ρθΦ=000 BeansHidden! I know you said you did, but according to the log, all the errors returned are referencing mysql Code: ... Just open this file: /var/lib/.openshift/cartridge_repository/redhat-ruby/../bin/control and add this line: https://github.com/openshift/origin-server/pull/5541 You can try on both stage/master. You should verify with the MySQL gem documentation for the verison you are using whihch version of MySQL is required.

Basic Geometric intuition, context is undergraduate mathematics Previous examples of large scale protests after Presidential elections in US? Also, I didn't install any server since Ruby already comes with WEBrick and I figured I would stick with that for now. The time now is 01:53 AM. http://rinfix.com/usr-bin-ld-cannot/usr-bin-ld-cannot-find-lxt.html Travis call home) Hot Network Questions As a monk, can I use Deflect Missiles to protect my ally?

error: ‘mysql_query' undeclared ... Thanks for the help thus far Fred. An error occurred executing 'gear postreceive' (exit code: 5) Error message: CLIENT_ERROR: Failed to execute: 'control build' for /var/lib/openshift/53a2d5b8f1da18b84c0000b3/ruby For more details about the problem, try running the command again with Vent kitchen hood vent to roof turbine vent?

yes creating Makefile make compiling result.c result.c: In function ‘rb_mysql_result_fetch_row’: result.c:258:31: warning: variable ‘tokens’ set but not used [-Wunused-but-set-variable] int hour, min, sec, tokens; ^ result.c:272:58: warning: variable ‘tokens’ set but So, I tried the port command first and got a port command not found error. done Your application 'r85s' is now available. However mysql is not showing up with the "gem list" command.

ERROR: Error installing mysql2: ERROR: Failed to build gem native extension. /usr/local/rvm/rubies/ruby-2.0.0-p598/bin/ruby -r ./siteconf20150120-23376-eypaci.rb extconf.rb checking for ruby/thread.h... more stack exchange communities company blog Stack Exchange Inbox Reputation and Badges sign up log in tour help Tour Start here for a quick overview of the site Help Center Detailed john: gem list *** LOCAL GEMS *** actionmailer (2.3.2) actionpack (2.3.2) activerecord (2.3.2) activeresource (2.3.2) activesupport (2.3.2) rails (2.3.2) rake (0.8.4) rubygems-update (1.3.1) ----------- And trying to generate a table is remote: remote: Gem::Installer::ExtensionBuildError: ERROR: Failed to build gem native extension.

Use `bundle show [gemname]` to see where a bundled gem is installed. Make sure that `gem install mysql -v '2.8.1'` succeeds before bundling. rc=255 .Last 10 kB of build output: Stopping Ruby cartridge Repairing links for 1 deployments Building git ref 'master', commit f1e38fb Building Ruby cartridge bundle install --deployment --path ./app-root/repo/vendor/bundle NOTE: You Any solutions yet?

Installing rake (10.1.1) <----skip----> Installing mysql (2.8.1) Gem::Installer::ExtensionBuildError: ERROR: Failed to build gem native extension. /usr/bin/ruby extconf.rb checking for mysql_ssl_set()...